Read only archive ; use https://github.com/JacORB/JacORB/issues for new issues
Bug 778 - the bug of the idl compiler for OMG idl files
Summary: the bug of the idl compiler for OMG idl files
Status: RESOLVED DUPLICATE of bug 773
Alias: None
Product: JacORB
Classification: Unclassified
Component: IDL compiler (show other bugs)
Version: 2.3.0
Hardware: PC Windows 2000
: P2 critical
Assignee: Gerald Brose
URL:
Depends on:
Blocks:
 
Reported: 2007-05-15 09:19 CEST by waterbig
Modified: 2007-05-15 09:37 CEST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description waterbig 2007-05-15 09:19:31 CEST
I cann't perform 'ant idlcmd' when installing JacORB.

also I meet some problems as below:
in window dos window,input idl -ID:\JacORB\idl\omg -ir *.idl
after that,I got the error message:
[jacorb.idl] ERROR : D:\work\idl\emsSession.idl, line: 623(1):
In operation emsSession.EmsSession_I.getEventChannel argument eventChannel clash
es with type CosEventChannelAdmin.EventChannel
[jacorb.idl] ERROR : D:\work\idl\emsSession.idl, line: 623(1):1 error(s).
[jacorb.idl] ERROR : D:\work\idl\emsSession.idl, line: 623(1):Parse error : 
Lexer errors

hint:#include "CosEventChannelAdmin.idl" in emsSession.idl file
Comment 1 Nick Cross 2007-05-15 09:37:18 CEST

*** This bug has been marked as a duplicate of 773 ***