Read only archive ; use https://github.com/JacORB/JacORB/issues for new issues
Bug 773 - the bug of the idl compiler for OMG idl files
Summary: the bug of the idl compiler for OMG idl files
Status: RESOLVED INVALID
Alias: None
Product: JacORB
Classification: Unclassified
Component: IDL compiler (show other bugs)
Version: 2.3.0
Hardware: PC Windows 2000
: P5 critical
Assignee: Gerald Brose
URL:
: 774 775 776 777 778 779 780 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-05-15 09:16 CEST by waterbig
Modified: 2007-05-15 09:38 CEST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description waterbig 2007-05-15 09:16:24 CEST
I cann't perform 'ant idlcmd' when installing JacORB.

also I meet some problems as below:
in window dos window,input idl -ID:\JacORB\idl\omg -ir *.idl
after that,I got the error message:
[jacorb.idl] ERROR : D:\work\idl\emsSession.idl, line: 623(1):
In operation emsSession.EmsSession_I.getEventChannel argument eventChannel clash
es with type CosEventChannelAdmin.EventChannel
[jacorb.idl] ERROR : D:\work\idl\emsSession.idl, line: 623(1):1 error(s).
[jacorb.idl] ERROR : D:\work\idl\emsSession.idl, line: 623(1):Parse error :
Lexer errors

hint:#include "CosEventChannelAdmin.idl" in emsSession.idl file
Comment 1 Nick Cross 2007-05-15 09:36:23 CEST
We would need the all the idl files to do a proper diagnosis but at first glance
I would say your name eventChannel clashes with type EventChannel - see CORBA 3
04-03-12 section 3.20 - identifiers are case insensitive so your argument
eventChannel should perhaps be named eChannel.
Comment 2 Nick Cross 2007-05-15 09:36:49 CEST
*** Bug 780 has been marked as a duplicate of this bug. ***
Comment 3 Nick Cross 2007-05-15 09:37:05 CEST
*** Bug 779 has been marked as a duplicate of this bug. ***
Comment 4 Nick Cross 2007-05-15 09:37:19 CEST
*** Bug 778 has been marked as a duplicate of this bug. ***
Comment 5 Nick Cross 2007-05-15 09:37:32 CEST
*** Bug 777 has been marked as a duplicate of this bug. ***
Comment 6 Nick Cross 2007-05-15 09:37:48 CEST
*** Bug 776 has been marked as a duplicate of this bug. ***
Comment 7 Nick Cross 2007-05-15 09:37:59 CEST
*** Bug 775 has been marked as a duplicate of this bug. ***
Comment 8 Nick Cross 2007-05-15 09:38:11 CEST
*** Bug 774 has been marked as a duplicate of this bug. ***