Read only archive ; use https://github.com/JacORB/JacORB/issues for new issues
Bug 311 - NamingService alias NameService does not work
Summary: NamingService alias NameService does not work
Status: RESOLVED DUPLICATE of bug 243
Alias: None
Product: JacORB
Classification: Unclassified
Component: Naming Service (show other bugs)
Version: 1.4.1
Hardware: PC Windows 2000
: P3 normal
Assignee: Gerald Brose
URL:
Depends on:
Blocks:
 
Reported: 2003-01-08 10:41 CET by Joonas Haapsaari
Modified: 2003-01-08 10:45 CET (History)
0 users

See Also:


Attachments
Fixed NameServer.java -file (10.07 KB, text/plain)
2003-01-08 10:42 CET, Joonas Haapsaari
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joonas Haapsaari 2003-01-08 10:41:12 CET
The predefined corbaloc alias for JacORB Naming Service is not functional. This
means that trying to locate the NS with the corbaloc
'corbaloc::127.0.0.1:2323/NameService' won't work. Furthermore, you cannot
override this single alias in the config file either as it is hard-coded.

It seems that in class org.jacorb.naming.NameServer there is some garbage before
the target in the line putting the mapping to the properties. This is easily fixed:

Replace (on line 218):

   props.put("jacorb.orb.objectKeyMap.NameService",
<    "%01StandardNS/NameServer%2DPOA/_root");

with

   props.put("jacorb.orb.objectKeyMap.NameService",
->   "StandardNS/NameServer%2DPOA/_root");
Comment 1 Joonas Haapsaari 2003-01-08 10:42:25 CET
Created attachment 26 [details]
Fixed NameServer.java -file
Comment 2 Gerald Brose 2003-01-08 10:45:46 CET

*** This bug has been marked as a duplicate of 243 ***