Read only archive ; use https://github.com/JacORB/JacORB/issues for new issues
Bug 412 - Bug 142 seems not to be fixed
Summary: Bug 142 seems not to be fixed
Status: RESOLVED DUPLICATE of bug 142
Alias: None
Product: JacORB
Classification: Unclassified
Component: ORB (show other bugs)
Version: 2.0 beta3
Hardware: PC Windows 2000
: P2 critical
Assignee: Nick Cross
URL:
Depends on:
Blocks:
 
Reported: 2003-11-17 11:36 CET by Jan Müller
Modified: 2004-01-07 14:59 CET (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Müller 2003-11-17 11:36:53 CET
We use JacORB 1.3.30 (POA) and have the problems mentioned in Bug 142 (large 
arrays of structs can't be sent to the client, 100 % CPU load on the server). 
Now we tried JacORB 2.0 Beta 3. Unfortunately, the problems are worse. Even 
data, that can be sent with 1.3.30, leads to problems in 2.0 beta 3.
We used the settings of the jacorb_properties.template

problems occur between 30.000 and 40.000 structures.

  struct ZahlungspartnerKurzform {
      wstring m_Zahlungspartner_Id; //char(8)
      wstring m_Art; //char(1)
      wstring m_Anrede; //is empty string
      wstring m_Name; //char(35)
      wstring m_Land; //is empty string
      wstring m_PLZ; //is empty string
      wstring m_Ort; //char(25)
      wstring m_Strasse; //is empty string
  };

  typedef sequence<ZahlungspartnerKurzform> ZahlungspartnerKurzformListe;

  ZahlungspartnerKurzformListe getZahlungspartnerKurzformListe() raises ( 
SaxMBSException );
Comment 1 Jan Müller 2004-01-07 14:53:22 CET
we tested the parameter bufferManagerMaxFlush and it seems to solve our problems
Comment 2 Nick Cross 2004-01-07 14:59:26 CET

*** This bug has been marked as a duplicate of 142 ***