Read only archive ; use https://github.com/JacORB/JacORB/issues for new issues
Bug 321 - Performance problems when "CDROutputStream too large"
Summary: Performance problems when "CDROutputStream too large"
Status: RESOLVED DUPLICATE of bug 142
Alias: None
Product: JacORB
Classification: Unclassified
Component: ORB (show other bugs)
Version: 1.4.1
Hardware: PC Windows 2000
: P2 major
Assignee: Gerald Brose
URL:
Depends on:
Blocks:
 
Reported: 2003-02-25 21:01 CET by alexmar
Modified: 2003-02-26 09:38 CET (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alexmar 2003-02-25 21:01:54 CET
When transferring a large number of objects (e.g. from a server to a client), 
in one call, then, after a predefined (4M?) limit, the internal buffer used in 
CDROutputStream is being re-allocated with a very small amount, so remaining 
data will be very slowly transferred (as the buffer is reallocated each time 
with that small amount).

A minimal solution would be to increase the buffer size with - for example - 
10% , right before BufferManager.getBuffer call, in CDROutputStream#check(int) 
method.
Comment 1 Nick Cross 2003-02-26 09:38:57 CET

*** This bug has been marked as a duplicate of 142 ***