Read only archive ; use https://github.com/JacORB/JacORB/issues for new issues
Bug 908 - Problem with connection, when server have multiple network interfaces
Summary: Problem with connection, when server have multiple network interfaces
Status: RESOLVED INVALID
Alias: None
Product: JacORB
Classification: Unclassified
Component: ORB (show other bugs)
Version: 2.3.0
Hardware: PC Windows NT
: P2 blocker
Assignee: Mailinglist to track bugs
URL:
: 909 910 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-03 17:16 CEST by sudam
Modified: 2011-11-01 09:54 CET (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sudam 2011-10-03 17:16:36 CEST
The server has multiple network interfaces. We want to use only one for communication. I am java developer and I don't know how Jacorb works. But we have one class in which there is selectProfile method which is called by Jacorb with profile list and ClientConnectionManager object as parameter. The problem is, as there are multiple interfaces on machine, Jacorb calls selectProfile method multiple times with different profiles. When it calls first time the connection is established as profile contains valid IP which my application use. But when selectProfile method is called second time, Jacorb gives invalid interface address and connection fails for that interfaces. So, is there any property for Jacorb so that it only creates profile for required network interface.
Comment 1 Nick Cross 2011-10-04 09:19:59 CEST
*** Bug 910 has been marked as a duplicate of this bug. ***
Comment 2 Nick Cross 2011-10-04 09:20:08 CEST
*** Bug 909 has been marked as a duplicate of this bug. ***
Comment 3 Nick Cross 2011-10-04 09:32:01 CEST
If you just want to use one host interface/port then look at OAIAddress/OAAddress as documented in the ProgrammingGuide and properties file.

If you want to use multiprofile IORs then this is a duplicate of 848 and am marking at as such.

*** This bug has been marked as a duplicate of bug 848 ***
Comment 4 sudam 2011-10-04 15:44:50 CEST
(In reply to comment #3)
> If you just want to use one host interface/port then look at
> OAIAddress/OAAddress as documented in the ProgrammingGuide and properties file.
> 
> If you want to use multiprofile IORs then this is a duplicate of 848 and am
> marking at as such.
> 
> *** This bug has been marked as a duplicate of bug 848 ***
> 

As per definition of select profile "Profile selectProfile(List _profiles, ClientConnectionManager ccm)", it should get list of profiles. But in my case it didn't get list of profile but jacorb call this method again and again for each profile. So, in my case when it calls first time connection is successful and for second time it fails to connect. so my question is why jacorb call selectProfile method again and again for each profile, is there any reason behind it? 

Comment 5 Nick Cross 2011-10-04 15:59:29 CEST
Have you changed the value of jacorb.transport.client.selector ?
Have you made your own plugin?

The defaultprofileselector should just choose the first profile from the list and return that.

What is the IOR of your server? 
Comment 6 Nick Cross 2011-10-06 15:47:05 CEST
Without further information it is difficult to help. Please supply the requested information and ideally a reproducible test case and reopen the ticket if still a problem.
Comment 7 sudam 2011-10-13 09:57:01 CEST
Hi,
Sorry for late response. Please see inline comments
 
1.Have you changed the value of jacorb.transport.client.selector ?"  
- yes we have our own implementation of selector and this property is set to selector class name. And we have selectProfile(List _profiles, ClientConnectionManager ccm) method in this class. But this method get profiles one by one which also include wrong interface name.

2.What is the IOR of your server? 
- currently I am not able to get IOR of server but I let you know once have it.



Comment 8 Nick Cross 2011-10-13 11:35:15 CEST
Please clarify what you are trying to do - for instance are you trying to connect to one specific profile in an IOR?

What ORB is the server using? 

Can you supply the code to your selector? Can you supply a test case?

Comment 9 Nick Cross 2011-11-01 09:54:29 CET
No response - closing for now.