Read only archive ; use https://github.com/JacORB/JacORB/issues for new issues
Bug 837 - ImR opens two endpoints only one beng usable
Summary: ImR opens two endpoints only one beng usable
Status: ASSIGNED
Alias: None
Product: JacORB
Classification: Unclassified
Component: Implementation Repository (show other bugs)
Version: 2.3.0 beta 2
Hardware: All All
: P2 normal
Assignee: Mailinglist to track bugs
URL:
Depends on:
Blocks:
 
Reported: 2008-08-15 21:57 CEST by ciju john
Modified: 2011-02-20 04:00 CET (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ciju john 2008-08-15 21:57:59 CEST
Playing around with jacorb.imr.endpoint_host & jacorb.imr.endpoint_port_number I noticed couple of things:

1. Setting the above configuration creates a listener (confirmed with lsof on Linux), but that endpoint isn't part of the ImR ior.
2. The ImR always listens on two endpoints.One of them is created by the ORB and the second is opened by the ImR app.
3. The ImR opened endpoint (via jacorb.imr.endpoint_host/endpoint_port_number) isn't usable. Clients trying to connect on it get a TRANSIENT exception.

I verified the above by using imr_mg as client to the ImR. The IOR is read with TAO catior utility and open sockets confirmed with lsof.

Has anyone else run into this or does anyone recall this ever working? Is anyone working on a fix for this or know the reason behind this behavior and how to go about fixing it?

thanks,
Ciju