Read only archive ; use https://github.com/JacORB/JacORB/issues for new issues

Bug 1032

Summary: IOR is not connecting to correct device
Product: JacORB Reporter: Amit Chaurasia <amitchrs8>
Component: ORBAssignee: Mailinglist to track bugs <jacorb-bugs>
Status: NEW ---    
Severity: blocker CC: amitchrs8, jacorb
Priority: P5    
Version: 3.6   
Hardware: Other   
OS: Linux   

Description Amit Chaurasia 2016-05-26 22:23:01 CEST
I have two Network elements where Corba is running. Each Network element has two Iors , lets say ior1 and ior2 where ior2 is obtained from ior1 like ior1.getior2() will return ior2. Both the network element have different ip Address with which I make a connection. Here I see two issue when they are put in an environment where multiple requests are made simutaneously.

 1.sometimes when I call ior1.getior2() on the ior1 of first Network Element , it returns the ior2 of second Network Element.

 2.In this case, the iors return correctly i.e. both iors belong to same Network Element but if I make any other call on ior2 of first Network Element, it gives me data of second Network Element.

This happens only when multiple threads are running in parallel.
Please let me also know if there is already a bug filed for this issue.
Comment 1 Amit Chaurasia 2016-05-26 22:27:15 CEST
Please let me know if anyone needs the logs to analyse it.
Comment 2 Nick Cross 2016-06-02 04:29:57 CEST
Can you reproduce the problem on git head (or snapshot) ? 

Can you provide a standalone test case?