Read only archive ; use https://github.com/JacORB/JacORB/issues for new issues

Bug 774

Summary: the bug of the idl compiler for OMG idl files
Product: JacORB Reporter: waterbig <xschema>
Component: IDL compilerAssignee: Gerald Brose <gerald.brose>
Status: RESOLVED DUPLICATE    
Severity: critical    
Priority: P5    
Version: 2.3.0   
Hardware: PC   
OS: Windows 2000   

Description waterbig 2007-05-15 09:16:28 CEST
I cann't perform 'ant idlcmd' when installing JacORB.

also I meet some problems as below:
in window dos window,input idl -ID:\JacORB\idl\omg -ir *.idl
after that,I got the error message:
[jacorb.idl] ERROR : D:\work\idl\emsSession.idl, line: 623(1):
In operation emsSession.EmsSession_I.getEventChannel argument eventChannel clash
es with type CosEventChannelAdmin.EventChannel
[jacorb.idl] ERROR : D:\work\idl\emsSession.idl, line: 623(1):1 error(s).
[jacorb.idl] ERROR : D:\work\idl\emsSession.idl, line: 623(1):Parse error :
Lexer errors

hint:#include "CosEventChannelAdmin.idl" in emsSession.idl file
Comment 1 Nick Cross 2007-05-15 09:38:10 CEST

*** This bug has been marked as a duplicate of 773 ***